2
\$\begingroup\$

I’ve set up a launch image in XCode and it does show up in the simulator, but on the Apple TV it just displays a blurry gray background. The image is the correct size and doesn’t have any transparency.

I have tried full clean and delete the app from the device – neither has worked.

\$\endgroup\$
1
\$\begingroup\$

After multiple deletes from the device, clean and device and XCode restarts, it magically started working, though not always 100% reliably. Seems to be "one of those things".

\$\endgroup\$
  • \$\begingroup\$ Thanks for coming back and posting an answer to this issue :) \$\endgroup\$ – Vaillancourt May 2 at 12:30
  • \$\begingroup\$ If you find the exact order of operations that works 100% please post it and add the particular tvOS version. The OS probably uses both an on-storage cache (for quick display on launch) and in-memory cache (running OS) and either of those being stale will cause the image to not get updated. \$\endgroup\$ – Stephane Hockenhull May 2 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.