0
\$\begingroup\$

The "legs" of my playermodel are shown when looking down. I'm using the Unity First Person Controller template.

Character when in Scene view:

Character in Scene view

Character when looking down in Play mode:

Character in Play mode

\$\endgroup\$
0
\$\begingroup\$

You can use Layers to control what's visible to each camera.

First, create a layer for "FirstPersonHidden" objects, following the instructions in the docs.

For each object you want to hide, set its layer to this one using the Layer drop-down menu at the top-right of the Inspector.

Then, on your camera, open up the Culling Mask drop-down and ensure this layer is unchecked.

Now the marked objects will be hidden from your camera's view.

\$\endgroup\$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.