1
\$\begingroup\$

So, i'm developing a game in unity and avoided baking lightmaps untill now ( i just assembled my new workstation setup wich is capable of baking the lightmaps and not the computer ). And now i have opened my project, imported it nicely and all, went to the lightning tab and clicked generate lightning ( naturallly i had auto-bake disabled). And everytime i do that i get a billion errors, and they do not stop popping up even after i force stop & cancel, i have to clear baking data in order to do anything ( of course unity is laggy as hell when it's spitting out these errors ). I even tried just a simple scene with just a plane on it. It's the same.

I checked and it works fine on another empty project, wich lead me to the conclusion that some texture in my assets folder is causing the error even though it's not on the scene at all. In this case i'm kina doomed, i have absolutely 0 idea wich texture could this be ( i have quite a lot of them) and why would it even cause problems. Any way to check that? Or maybe does somebody know another possible reason for this problem? I tried to do research but found literally nothing. No thread about the issue, nothing. Not even the same errors.

Thanks in advance.

Here are the errors[1] PS: i have baked & realtime GI disabled

\$\endgroup\$
  • \$\begingroup\$ Have you tried deleting your library folder and re-opening Unity to force it to re-import all your files? Another thing to check is the file & folder permissions — I had a case once where some of my textures were exclusive to one user account and would cause errors when Unity was run by another user. \$\endgroup\$ – DMGregory Jan 4 at 20:49
  • \$\begingroup\$ @DMGregory Sorry for the veery late reply. I tried that and it's the same. Just getting spammed with errors. No idea if this is relevant at all, but my card is AMD RX VEGA 64. \$\endgroup\$ – Koteu Jan 20 at 12:10
  • \$\begingroup\$ Oof. Have you tried copying batches of assets from your project with broken lightmapping over into the new project where lightmapping works? If at some point it breaks, you can narrow down the problem asset to one in the most recent batch. And if it doesn't ever break during that process, then you end up with a new copy of your project, assembled Ship of Theseus style, without the error. ;) \$\endgroup\$ – DMGregory Jan 20 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.