I am creating a 2D game in Unity. The sprites in my game appear to have their pixels only allowed to be in set positions of the screen, making the textures sort of aliased to a low degree that causes things to display not as I intended when in motion. I've looked up how to correctly import pixel art sprites, and I have all the sprite import settings correct to my knowledge (filter mode = point, compression = none). I believe this must be a project setting that needs to be changed but for the life of me I can not find it. The sprite is rendered how I want it to be in the editor view, I will show you a comparison of the two so you know what I want.

enter image description here

[above]This is what it looks like in game, not what I want

enter image description here

[above]This is what it looks like in the editor, what I want the game view to look like.

Edit: So I tested actually building the game and running it, and it appears to look more smooth like how I want it to be. It is still slightly jagged, but I think that's because I have no anti-aliasing; it's very minor. Still, i would like to have a way to make it look this way in the editor game view. It would help me determine how good certain animations look without having to build the game each time. Is this possible?

  • How have you configured the resolution and zoom on your game window inside the editor? And are you rendering to a RenderTexture at any stage in your pipeline? – DMGregory Dec 2 at 1:45
  • I have the game view set to a 4:3 aspect ratio. The zoom is at 1x. I do not believe I am rendering to a RenderTexture, unless it's possible to be doing that without explicitly setting it up. – Morgan Dec 2 at 2:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.