0
\$\begingroup\$

Using Unity 2018.2.14/15 I've recently been working on a small project and I encountered a very weird problem. It's hard to describe so here is a picture:

enter image description here

Originally I assumed it may be an issue with my shadow/lighting settings (I think it looks like that a lot), but I couldn't find any setting that had a direct impact on the lines.

Ignoring it sadly isn't an option and I don't know of any workaround...

Some additional information:

  1. The problems are 2-3 well visible decreases in lighting brightness. It seems a bit like there is something causing automatically descending lighting quality the further away from the camera the walls are, however I haven't found a setting to change this yet.
  2. Currently I'm using quads and a custom material based on the Standard Opaque Shader with an Albedo setup. I'm using a self-made Texture for the walls (and a normal map created from a grayscale/bumpmap version of the texture). However, I've also tried changing between all non-round Unity Standard Models with no result.
  3. The lines are indeed dependent on Camera Distance (both Editor and ingame Camera). If I move the walls, the lines stay at the same position on the walls (like on a certain spherical radius around the camera). If I move the camera (editor and ingame camera display different lines) the lines move together with it.

Do you have any idea what's going on/what I can do to prevent those lines from appearing?

Thank you in advance! :)

\$\endgroup\$
  • 1
    \$\begingroup\$ Can you give us more details about what's happening here? Firstly: describing your problem in words can make it more searchable, so other users experiencing similar issues can find it and share knowledge. Secondly: what's the makeup of the surface the light is shining on? Is it a flat quad of geometry with a normal map, or are you using parallax occlusion mapping, or is there additional geometric detail there? Third: how does this effect look in motion? Does the line move if you move the camera? If you move the light? If you move the wall alone without moving the lights? \$\endgroup\$ – DMGregory Nov 23 '18 at 3:00
  • \$\begingroup\$ Sorry for missing out on posting some important informations earlier and thank you for you suggestions. Meanwhile I found the solution myself and updated the post. \$\endgroup\$ – BloodEchelon Nov 23 '18 at 10:33
0
\$\begingroup\$

So it seems that the problem was actually the auto-generated MipMap on the normal Map. At certain distances from the camera the decreased MipMap quality lead to the mentioned rendering artifacts/problems. Turning off the MipMaps (Located within the Import Settings of the Texture under Advanced -> Generate Mip Map) solved the problem. Alternative solution: Set the Filter Mode of the Texture to Trilinear (instead of turning off the MipMap)

\$\endgroup\$
  • 1
    \$\begingroup\$ Trilinear filtering is probably the better solution, as keeping mipmapping enabled helps reduce aliased shading in distant or obliquely-viewed objects, and makes better use of your GPU's texture cache to keep rendering humming smoothly. \$\endgroup\$ – DMGregory Nov 23 '18 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.