0
\$\begingroup\$

I was trying to create IK constraint following a Nathan Vegdahl tutorial, and everything was nice and shiny, until i tried to actually move a bone. It's not moving, only rotating. I see that transform lock panel on location is grey and completly locked, and i have no idea what's wrong.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Did you know we have a dedicated Blender StackExchange? While questions asking about how to use Blender to implement game assets & features are not off-topic here, you might find there's a higher density of users able to answer your questions about Blender specifics on the tool-specific SE. Please note that cross-posting is discouraged here, so if you decide to post this question on the Blender SE, please delete the copy here, so we don't split the answers between two different sites. \$\endgroup\$ – DMGregory Nov 17 '18 at 15:25
0
\$\begingroup\$

What you see is normal behaviour. A bone is defined by two points, the head and tail (also called root and tip).

When a bone is connected to its parent bone, in pose mode you are unable to move the head, you can only rotate the bone so that its tail is in a different location.

To move the head of the bone you need to rotate its parent bone so that the connecting point is in a different location.

Blender provides user feedback by fading out the location of the bone when you can't directly edit that property using the current selection.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.