0
\$\begingroup\$

This image show the problem

Also it's important to mention that I'm using LightweightPipelineAsset for Scriptable Render Pipeline (so I can use PBR graphs)

Problem is that surfaces that SHOULD be drawn they AREN'T and the ones that SHOULDN'T be drawn are actually drawn. So for that reason if I get in with camera in object it works normally but from external side it don't works.

Edit1:

For example if object is exported in .obj it works, but that blender model have animation so it's exported as blender file and then not working...? Similar blender file without animation is working.

\$\endgroup\$
  • 1
    \$\begingroup\$ looks like it's a problem with your model's normals. Check in blender if the normals are facing outwards, by enabling "Back Face Culling" in the panel opened using the "N" key. Also in unity check if the normals of the model are "Imported" and not "Calculated" \$\endgroup\$ – Gabriele Vierti Nov 10 '18 at 20:20
  • \$\begingroup\$ @GabrieleVierti You should post this as an answer. \$\endgroup\$ – Philipp Nov 11 '18 at 1:31
  • 1
    \$\begingroup\$ I found the answer on the internet. blender.stackexchange.com/questions/63642/… \$\endgroup\$ – Zdrav Nov 11 '18 at 7:21
0
\$\begingroup\$

It seems that you are having some problems due to your model's normals.

To fix this, open your model in Blender, and check which faces are facing the wrong way by opening the right side panel using the N key;
Scroll down until you see a Backface Culling option, then check it; This is going to help you spot the mistakes with your model, by not rendering the faces with incorrect facing normals.

Now all you need to do is to go into Edit Mode, select all the incorrect faces, go to the bottom menu, and select Object/Normals/Recalculate Outside (Ctrl+N is the shortcut).

If this still doesn't fix the problem , it might be a problem with the way Unity is importing your model.

When you import the model into Unity, scroll down until in the Import Settings tab, until you see the Normals option, and set it to Import instead of Calculate.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.