1
\$\begingroup\$

Back in the day it worked, but for some reason in my new projects it isn't.

Every other asset's difference is shown correctly in a text format (i.e. .prefab), only .unity files won't work, in the diff view it says:

No changes in this file have been detected, or it is a binary file.

I did these:

  • In Project Settings > Editor, Asset Serialization is set to Force Text.

  • Created a .gitconfig in the root of my repo, with this content: (the path is correct)

    [merge] tool = unityyamlmerge [mergetool "unityyamlmerge"] trustExitCode = false cmd = 'C:\Program Files\Unity\Editor\Data\Tools\UnityYAMLMerge.exe' merge -p "$BASE" "$REMOTE" "$LOCAL" "$MERGED"

  • Also in SourceTree > Tools > Options > Diff, I increased a few limits, set the external diff and merge tool to C:\Program Files\Unity\Editor\Data\Tools\UnityYAMLMerge.exe but none of them helped.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.