1
\$\begingroup\$

i stumbled upon a problem, can't figure out what's the reason and how to solve it.

I have glass-windows which use just the standard (specular setup) shader. in the first place when the model is added to the scene the glass looks like this (wrong !) enter image description here

Then JUST by clicking on the little arrow to deploy the extra infos about the material the glass suddenly looks like it is supposed to look : enter image description here

Is this a unity bug ? i actually change absolutely nothing, just click the material.

Is there a way to force this to occur on itself ? i tried by disabling an re-enabling mesh renderer but it does not do the trick.

edit: seems that putting rendering mode to anything else and setting it back to transparent helps to obtain the same result as clicking the little arrow. nevertheless this is very strange

thanks for any help

\$\endgroup\$
  • \$\begingroup\$ Hi dear psypol welcome to gamedev stackexchange.I tested this but It works correctly without need clicking.I need more information like what is version of your unity.can you upload sample scene because sometimes bugs work on the specific situation \$\endgroup\$ – Seyed Morteza Kamali Oct 4 '18 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.