0
\$\begingroup\$

I have a hook with hinge joint which is working fine but as my object quickly move my hook leave its position for a while.

enter image description here

And here is the hinge joint settings with rigidbody:

enter image description here

Here is a short clip of the problem.

\$\endgroup\$
2
  • \$\begingroup\$ How are you moving the object atm? \$\endgroup\$ – DMGregory Sep 28 '18 at 10:49
  • \$\begingroup\$ Object is crane which is moving through animation \$\endgroup\$ – Muhammad Faizan Khan Sep 28 '18 at 10:55
1
\$\begingroup\$

It may depend if you're using animation for move parent object.

If you move the object using it's transform this could not happen.

\$\endgroup\$
1
  • \$\begingroup\$ Yes You maybe right.!! I have found the answer. \$\endgroup\$ – Muhammad Faizan Khan Sep 29 '18 at 5:51
1
\$\begingroup\$

The parent object which was moving the Hook working through animation and by setting its animator update mode to AnimatePhysics, the problme has resolved. What Animate Physics property do is:

When turned on, animations will be executed in the physics loop. This is only useful in conjunction with kinematic rigidbodies.

An animated platform can apply velocity and friction to rigid bodies sitting on top of it. In order to use this, animatePhysics must be enabled and animated object must be a kinematic rigid body.

Now the animation is executing in same physics loop which has resolved the issue.

Thanks to Chance Millar.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.