0
\$\begingroup\$

I have imported a new texture into UE, and have created a new sprite. I have setup the material of the sprite as follows:

some material for pixel-art texture

I have also set my texture as texture-parameter. But my sprite renders brighter than its texture:

sprite brighter than texture

Why? What am I doing wrong?

Thank you in advance.

\$\endgroup\$
1
  • \$\begingroup\$ It is probably the lighting in the scene - you can try to view your scene as Unlit (in editors viewport) then the texture should be the same colors as in the texture editor. \$\endgroup\$
    – ColdSteel
    Jun 28 '19 at 18:23
1
\$\begingroup\$

Check the camera and light settings. The default camera uses eye adaptation to make everything in dark scene gradually brighter.

\$\endgroup\$
0
\$\begingroup\$

Try checking the sRGB checkbox and maybe change the compression settings. You could also try changing the brightness and brightness curve values.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ What should the compression/brightness settings be changed to? \$\endgroup\$
    – DMGregory
    Jan 5 '19 at 14:30
  • \$\begingroup\$ I usually go for default or BC7. However, I doubt any compression setting will do alot of change. You will get the biggest change out of the sRGB and brightness settings. I suppose the reason why it looks different in your game are all the shaders that are applied (unreal also enables alot of shaders by default). Lighting plays a big role too of course. \$\endgroup\$
    – sei556
    Jan 5 '19 at 16:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .