0
\$\begingroup\$

I'm using Unity and have a 2D project. I'm trying to add a background image to my project/scene, but I'm unable to.

Adding smaller .png files to the project work fine, by simply dragging them onto the Hierarchy tab. My background image, and larger images, do not work though. Below is the image in question:

enter image description here

It's a 66kb png. Nothing weird about it.

How should I be adding it as a background if I'm unable to add it as a sprite?

Below is the assets settings under Import Settings:

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Can you select the asset in your Project window and show us the import settings that appear in the Inspector? \$\endgroup\$ – DMGregory Sep 1 '18 at 23:21
  • \$\begingroup\$ Sure @DMGregory, I've edited the question \$\endgroup\$ – mikemike Sep 1 '18 at 23:23
2
\$\begingroup\$

At the top of the Inspector, change the "Texture Type" to "Sprite (2D and UI)"

Sprites support dragging them straight into the hierarchy, which automatically generates an object with a SpriteRenderer to display them. Other textures need to be sampled by a material assigned to a renderer, so they're not quite as quick to add to a scene.

|improve this answer|||||
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.