0
\$\begingroup\$

I was messing around a random project and everything was working perfectly, when all of a sudden jagged edges appeared on all objects. I've been trying to resolve this issue for the past two dails, only to no avail. I have tried changing various settings, when at last I've uninstalled unity and removed all projects. After re-installing it, however, the problem still persists:

enter image description here

What I've tried:

  • changing settings in Nvidia Control Panel (for example, settingantialisaing mode to application-controlled)
  • changing the Quality settings inside Unity
  • removing any normal/texture maps
  • changing metallic and smooothness of the material and removing specular highlights
  • reinstalling Unity

These pictures depict current settings/object properties:

Properties of material added to the cube

enter image description here

Camera properties:

enter image description here

Quality settings:

enter image description here

Graphics settings:

enter image description here

enter image description here

\$\endgroup\$
4
  • 3
    \$\begingroup\$ Your game view is scaled x3.47. When the game view is scaled, Unity just "stretch" the output of the camera. Set it back to x1 \$\endgroup\$
    – Hellium
    Aug 25, 2018 at 9:58
  • \$\begingroup\$ @Hellium: that looks like a good answer to me. :) I've also had similar effects show up due to desktop scaling on Windows for high-DPI displays. \$\endgroup\$
    – DMGregory
    Aug 25, 2018 at 12:07
  • \$\begingroup\$ @Hellium, thank you very much! This indeed fixed the problem! \$\endgroup\$ Aug 25, 2018 at 14:52
  • \$\begingroup\$ @AnimaVivens I don't think Hellium has any intention to turn his comment into an answer (should have been an answer to begin with), so if you could put an answer as to how you fixed this, it would be appreciated. (P.S. I know it's just right there, in the screenshot, but still, an answer would be nice.) \$\endgroup\$ Aug 27, 2018 at 11:25

1 Answer 1

1
\$\begingroup\$

The jagged edges were present due to the fact that the game view (first image in my post, the panel in the right part of the image) has been scaled to 3.47, instead to 1. Scaling the game view to 1 resolved the issue.

Thank you for the answer @Hellium and for the suggestion to answer @John Hamilton

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .