1
\$\begingroup\$

Time.timeScale = 0 obviously works to stop physics but it's also stoping my Invoke calls. How can I get around this to pause ONLY the game physics?

EDIT

Temporarily I'm using isKinematic = true on all of my rigid body objects via event trigger.

\$\endgroup\$
  • \$\begingroup\$ watcha making? just curious \$\endgroup\$ – Evorlor Aug 23 '18 at 12:07
  • \$\begingroup\$ Time.timeScale = float.epsilon; is a hack that I have done in the past. \$\endgroup\$ – Evorlor Aug 23 '18 at 12:11
  • 1
    \$\begingroup\$ @Evorlor it's a limited augmented reality prototype. I want the scene to setup but keep all physics paused while the get-eady timer counts down at which point everything because active \$\endgroup\$ – Jacksonkr Aug 30 '18 at 16:20
2
\$\begingroup\$

Turn off auto physics simulation:

https://docs.unity3d.com/ScriptReference/Physics-autoSimulation.html

Or if you happen to be doing 2D:

https://docs.unity3d.com/ScriptReference/Physics2D-autoSimulation.html

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.