0
\$\begingroup\$

I have a model made by Blender that has animation in it. However when I imported this model in Unity and played the animation, Unity automatically interpolated position between frames.

I heard from someone that change the frame rate exactly same will solve this, but I want to keep the Unity's frame rate and Blender's animation frame rate same. There are two reasons:

  1. Frame rate in Unity automatically changed which platform to play. I want to keep this feature, so that I can use single model to different platforms.
  2. I don't want to all animation clips are not interpolated. Only I needed is some of them, just few keyframes in specific animation clip.

So what I want to do exactly is disable animation interpolation in only in specific clip. If I can edit only keyframe could be perfect.

However I struggled in this issue almost an year and tried many different things but none of them worked. Especially turning off each option in Unity was useless.

Most I found was change the curves to tangent or flat, but I can't do that because imported clips are read-only. I could duplicate the clip and fix that, but there are too many models and animations to do that. Also when I duplicate animation clip from imported model in Unity, there's no preview and it was really really hard to find exact position of keyframe that want to change the curve. And most important, it wasn't worked(or maybe something I wrong, but there's no way to check this).

So how do I disable animation interpolation to imported animation in Unity? Any advice will very appreciate it.

\$\endgroup\$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.