0
\$\begingroup\$

Arter setting one IK on my control rig, when I start to set the next IK, the previous one resets to its prior state.

Here's an example of my problem:

enter image description here

How can I keep the previous IK from resetting?

\$\endgroup\$
1
\$\begingroup\$

update 18-7-11 finally I find the best way is use maya "Auto Key" enter image description here

update 18-7-11 I find my old solution is not good, it cause I cannot select time slider, so I should use following way to instead:

I should following way to fix it:

scripJob -attributeChange 

when attributeChange, auto save key

update 18-7-10 following is my code to fix this bug, invoke my code fix meth in maya script editor > python

import maya.cmds as mc
from kernel import *
def fix():
    mc.scriptJob(event=["timeChanged", reselect_character])


last_key_frame = None


def reselect_character():
    """
    I cannot find maya python get cur character func, so I default use ro_character character set
    :return:
    """
    global last_key_frame
    cur_key_frame = mc.currentTime(query=True)
    if cur_key_frame == last_key_frame:
        last_key_frame = cur_key_frame
        return
    character_set_name = "ro_character"

    if (not mc.objExists(character_set_name)):
        mel("character -name " + character_set_name + " -excludeVisibility -excludeScale;")
    mel("setCurrentCharacters( { \"" + character_set_name + "\" } );")

update 18-7-9 I find this bug occurs when time slider click(time change)

when i create character set, and reselect current same character set("No Character Set" doesn't work), the ik will not be reset, the bug wil fix

how to:

make maya script

update -timeChange cannot when click time slider, use scriptJob > timeChanged Cond; maya mel: scriptJob -timeChange, it can detect time slider change,

when time slider change, reselect current character set

if not character set, create character set in maya script

following soluiton doesn't work, see above solution

I guess it's bug in maya 2017, when i preferences > settings > time slider > key ticks > select "channel box" and click save

it fixed, and then i select "key ticks" > "active", it still fixed

I guess maybe my prefs interrupt and when i click Preferences > "save", the prefs will return to normal

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.