I am using the Lightweight Scriptable Render Pipeline 1.1.11-preview and I have two lights in the scene. One is a Sun light and another is an uplight. The Sun light is set to cast dynamic shadows, as are the particle effect clouds and the models. I am expecting the clouds and the cloudship (the floating thing in the middle of the picture) to cast shadows.

The sand is procedurally generated: a flat prefab is loaded at run time and the y points are set by Perlinn noise. I recalculate the normals using Unity's method.

Here is the scene:

Rendered scene without clouds

The properties of the Sun light:

The Sun light properties window

The prefab for the sand (which I am expecting to have shadows):

Sand prefab properties window

Here is the lighting properties.

Scene lighting properties screen

The setting window for the Lightweight Pipeline:

Lightweight scriptable pipeline

The settings for the mesh that should be casting the shadow:

enter image description here

Is there anything I'm missing? Thanks in advance.


1 Answer 1


In Lightweight Render Pipeline asset, my distance was set to 50. As my objects are large and set outdoors, this was not far enough to cast shadows. Below, I have set it to 6000 units, which is roughly the render distance of my scene.

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .