0
\$\begingroup\$

I have recently upgraded to Unity 2017.4.5. This required me to reimport TextMeshPro which I used previously in the project. Now I am trying to build (Android, Windows) and it is giving me hell a lot of errors, but I do not have any when I want to run the project. It is yelling about TMP, it does not find specific scripts. I tried to move around the runtime and the editor dll, reimporting all, googleing the error message, but it did not help.
Please see my errorlog: http://pasted.co/35185b3c.
Thanks

\$\endgroup\$
1
\$\begingroup\$

Have you tried uninstalling and reinstalling the TMP package ? It seems like unity is not finding any of the file corresponding to the asset. I know I had ussues too with TMP when I upgraded my unity version but it was solved after reinstalling unity as a whole (I formatted my computer for other reasons)

\$\endgroup\$
  • \$\begingroup\$ Yes, but it did not help... \$\endgroup\$ – formatc2013 Jun 29 '18 at 2:16
1
\$\begingroup\$

Actually, the problem was the version of the TMP, I'd had . I had to delete the TextMesh Pro Unitypackage from my:

C:\Users\MYUSERNAME\AppData\Roaming\Unity\Asset Store-5.x\Unity Technologies\Unity EssentialsBeta Content

and then I reinstalled TMP from the Asset Store, and it works now.

This post might be helpful for someone else, that is where I found my answer.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.