0
\$\begingroup\$

I am trying to make my 2D mesh render sprites with the same brightness as the original file.

On the below picture, the mesh on the left is darker than the UI Image on the right, which is an exact likeness of the original file. How can I make the mesh as bright as the Image?

So far, I've been looking into the following potential culprits:

  • Shader attached to the Mesh
  • Global lighting settings
  • Mesh renderer lighting settings

enter image description here

The above image is with Environment Lighting > Ambient Color at #FFFFFF.

Environment Lighting > Ambient Color > Intensity doesn't help.
Increasing the shader's emissions can offset the darkness but it's not an ideal solution.

All other lighting settings both globally and on the Mesh Renderer are default.

At this point, I'm lost :/
Any help would be much appreciated!

\$\endgroup\$
1
\$\begingroup\$

The solution was the shader type.
Changing Shader Standard -> Shader Unlit/Texture, solved the issue!

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.