0
\$\begingroup\$

Recently I noticed that my builds seem to have a weird graphical bug. This only occurs when I play a build. Running the game in VR in unity play mode doesn't show this bug.

I am not sure what is causing this or what it is even called. I do remember in the old days windows having a similar bug where you could draw on your screen basically by dragging an interface. I have an older build where this glitch didn't occur and checked the settings I had then and now and nothing changed.

Developing in VR is still fairly new to me so if it is anything basic I might not be aware of it.

My Unity version is 2017.2.0f3 with the latest SteamVR version using the HTC Vive, which has been running on the same version as when the bug didn't occur.

This link is a video of the bug occurring during the play mode in a build (in the menu the bug didn't occur strangely enough).

This link is a video of it being run in play mode. This is what I would expect in a build as well.

Just watching the first few seconds of both videos is plenty to understand the issue I am experiencing.

Thanks in advance.

Edit: I have discovered that this issue is called ghosting. I hope this helps anyone.

\$\endgroup\$
0
\$\begingroup\$

Alright I am not exactly sure what fixed it, but after figuring out it was called "ghosting" I did some research on other projects and people experiencing the issue in combination with Unity and VR.

First I updated my nVidia drivers for my graphics card... didn't seem to solve the ghosting. After that I decided to look at the assets.

I completely removed the SteamVR asset and redownloaded it from the store. Then I imported the CameraRig prefab (as I am using it) and tweaked some settings to suit my needs. After that I ran a test build and the ghosting bug was gone. So I added my own components to the CameraRig and still no ghosting.

I tested this in various builds with different settings (even with single pass rendering) but the ghosting issue is gone. Currently I am flabbergasted since this bug came out of nowhere and disappeared into thin air.

If anyone in the future experiences the same, redownloading the asset seems to fix it somehow.

And if someone is able to enlighten me a bit more about this I'd be grateful.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.