1
\$\begingroup\$

The Unity editor scene renderer is not letting me get a close-up view of anything. As the camera moves closer, the geometry closest to the camera just disappears. It's as if the draw distance has become far-sighted.

Bad Unity View

In the example above, the geometry of the green object (a car mesh) is being cut off as I pull the camera in. The floor is also disappearing, as shown by the grey cut-off at the bottom.

This is making is extremely difficult to line up colliders with render meshes, position smaller objects, and do other detailed tasks. I don't remember my Unity doing this before about a month ago, but I have no idea what changed. Is there a setting somewhere? Has anyone else seen this?

\$\endgroup\$
1
\$\begingroup\$

Select the object you want to look at and press F to focus the camera on it. It automatically adjusts the near and far clipping planes.

\$\endgroup\$
0
\$\begingroup\$

Check the scaling of your objects. Chances are the objects are way too small or way too big. Adjust the scaling accordingly in the Mesh Import settings, and try to keep the model scale 1, 1, 1 in the inspector.

I don’t know of any way to adjust the clipping distance in the inspector scene view.

\$\endgroup\$
  • \$\begingroup\$ Looks like my scales are all (1, 1, 1) already. \$\endgroup\$ – Nightmare Games May 20 '18 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.