0
\$\begingroup\$

I was trying to follow a tutorial for my first unity tests and I can't seem to convince unity that I indeed have an internet connection, short of a complete uninstall I tried about everything I could think of or find on google:

  • Running unity as an admin
  • Reseting my TCP-IP with a Microsoft tool
  • Deactivating my firewall
  • Deactivating windows 10 firewall for real and completelly (Because windows 10 sucks and I'd be using windows 7 if it weren't for docker)
  • Deactivating my AV software Logging out and in from unity

The browser will open the asset store no problem, I'm on windows 10

enter image description here

\$\endgroup\$
  • \$\begingroup\$ You should be able to download the packages you want off the asset store via the browser, then double-click on them to install them into your current project. That should help you work around the issue. As for the problem with Unity itself, it sounds like a bug to bring to their tech support team. \$\endgroup\$ – DMGregory May 17 '18 at 23:04
  • \$\begingroup\$ I think it might be due to my unity installation residing on a secondary drive \$\endgroup\$ – Jonathan dos Santos May 18 '18 at 0:17
  • \$\begingroup\$ @DMGregory nop, te download asset button on the browser tries to open the asset store in unity and leads to the same problem, Ive updated unity manually and still the same its either something wrong with the drive i`m on or with google auth \$\endgroup\$ – Jonathan dos Santos May 18 '18 at 0:54
  • \$\begingroup\$ found out the culprit \$\endgroup\$ – Jonathan dos Santos May 18 '18 at 1:08
1
\$\begingroup\$

Apparently my account was too old and had no username associated with it (I indeed had downloaded unity a couple years ago but did nothing with it), since I was logged in through google it would log in but didn't ask me to create a new username until clicked on the cloud button and I dug around on their site.

As soon as I created the username and restarted unity it would work.

Apparently the old account and outdated version confused the IDE.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.