0
\$\begingroup\$

I'm playing around with making a roguelike and I want to use ascii characters as tiles in the game. I'm using a 256x256 sprite map where each character ends up being a 32x32 box.

This works fine, however the sprites end up being weirdly drawn, especially when zoomed out. Take a look:

enter image description here enter image description here enter image description here enter image description here enter image description here

enter image description here

As you can see, only the biggest zoom-in has no weird artifacts in it.

I tried playing around with the settings here and that's the best configuration I can get. PPU at 32 or 256 or even 1 doesn't seem to make any difference. Disabling compression doesn't do anything either.

I've also tried using a sprite map where I resized it so every character is 256x256 but it's still the same problem when zoomed out.

\$\endgroup\$
1
\$\begingroup\$

You need to enable Mip Maps and filtering on minimisation.

Point filtering drops entire pixels rows and columns when scaling down (zooming out).

The downside of mip maps and filtering is your sprites won't have sharp pixels anymore and will be blended when zoomed out. You can't have it both ways.

\$\endgroup\$
0
\$\begingroup\$

I fixed it by using the DeadSimple Pixel Perfect Camera.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.