1
\$\begingroup\$

I have a model that has lots of animation clips(actions).

enter image description here

Before export as FBX, I set the pose to named "default" pose and exported as FBX like this.

enter image description here

But in Unity, it's changed to first animation clip in animation list in Blender!

enter image description here

I try to fix it, but there is nothing I can do. I can't change the order of animations in Blender and Unity either.

This wasn't first time, I had same issues before but I just ignored because it's fine in game play, but I really want to fix it this time.

What I want is set "default" pose in edit mode in Unity(not play mode). How do I set "default" pose as default, not first animation clip in the list?

Using Blender 2.78, and Unity 2017.3.0f3.

\$\endgroup\$
  • \$\begingroup\$ then simply set the animation to it? Check the animation components \$\endgroup\$ – Sidar May 7 '18 at 14:16
  • \$\begingroup\$ @Sidar Simply set the animation to what? \$\endgroup\$ – modernator May 7 '18 at 14:34
  • \$\begingroup\$ @Sidar And what is animation components? Do you meaning Animation Controller, or animation import settings? I already did both. Your answer is too vague. \$\endgroup\$ – modernator May 7 '18 at 14:37
  • \$\begingroup\$ Unity doesn't care about animation order. The clips are generated based on your import file. You then set the animation clip in mechanim or whatever the animation components do now. I haven't touched unity in a while. \$\endgroup\$ – Sidar May 7 '18 at 15:09
  • 1
    \$\begingroup\$ It might pick the first one it encounters sure, I'm just saying that it doesn't really have any significance other than that. There are a few topics on this some even suggest a script, but if naming shifts the order why not add a _ to your default -> _default this puts it first \$\endgroup\$ – Sidar May 7 '18 at 18:10
2
\$\begingroup\$

You should Know that Unity takes the "default pose" from the first frame of the first animation.

Also Unity classifies them as they are in blender:

enter image description here

[Solution] 1 - Always create an Idle Animation and set the "default pose" in the first frame, and rename it to be the first animation.

or

2 - set "default pose" on the first frame of your first animation(action) in blender, so Unity can understand that's the default pose.

(don't forgit to Reimport the .FBX in Unity after making changes)

| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

As Sidar said, change name of "Default" clip to "_Default" should be work. It's not complete solution, might be fix for now.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.