0
\$\begingroup\$

I have a small house with point light in it. But as you see, directional and sky lighting affect inside lighting. It's too bright.

How can I make that inside is only affected by point light and not by directional light. Or maybe just a small amount of directional light.

enter image description here

\$\endgroup\$
1
\$\begingroup\$

You can use layers to control what content is lit by which lights.

Interior-Exterior Lighting Example

Here I've built a room with two shells of geometry cladding: the exterior shell is in the Default layer, and the interior shell is in a new layer I called Interior.

My red point light's culling mask is set to light only the Interior layer.

My directional sunlight's culling mask is set to light every layer except the Interior.

I also edited my scene settings to drop the "Environment Lighting" ambient multiplier to zero, and added a couple of extra directional lights in a soft blue to make up for it. These fill lights also don't light the interior, and don't cast shadows.

\$\endgroup\$
-2
\$\begingroup\$

I think you might need to see this 16 min video about Unity's lighting.

LIGHTING in Unity . But the general idea is that your indirect lighting is too strong and you need to tweak the Directional light for indirect lighting as well the global lighting settings.

\$\endgroup\$
  • \$\begingroup\$ This doesn't appear to answer how to make interior spaces be lit differently than exterior spaces. \$\endgroup\$ – DMGregory Mar 31 '18 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.