0
\$\begingroup\$

I am working a cocos2dx project and trying to integrate Firebase C++ SDK in my project as below.

I have been following the instruction from Firebase Cocos2d-x Samples in github provided by Google for integrating some Firebase FIREBASE_FEATURE in Cocos2dx project. I followed all step successfully but when I build and run , I have been facing Linker error for Undefined symbols for architecture x86_64 like below picture

enter image description here

Anyone facing this problem like me?

Question:

Would you please tell me why this is happening and how I solve that? Is there any problem in Sample Project which is provided by Google?

N.B: I searched google and found some answer but didn't work.

\$\endgroup\$
  • 1
    \$\begingroup\$ If possible, use a cut & paste of the error text rather than a screen shot; it makes it easier for others to search. And if you tried something that should have worked but didn't, include the details of what you tried. \$\endgroup\$ – Pikalek Mar 7 '18 at 5:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.