1
\$\begingroup\$

I have a widget blueprint to show a main menu. Everything was fine until I recently added a new button in the menu to enable cheat codes. The problem started when I noticed when I changed the color of the button text, it would go back to white after I hit the compile button in the BP. I closed the BP and reopened it and that fixed that issue. However now, no matter what I have the color of the button text set to, it shows the correct color in the editor but as soon as I run the game the button text is white. I have tried clearing the Binaries folder and restarted the engine, cleared the Binaries and Intermediate folders and restarted the engine and I have cleared both Binaries and Intermediate folders and restarted my computer and the problem persists. The problem exists when I run the game from the editor, debug and shipping builds.

Here are the buttons from in the editor enter image description here

And here are the buttons when I run the game. It doesnt matter if I run it in PIE, Standalone Game, release build or debug build the text is white. enter image description here

Any ideas on how I can fix this issue?

\$\endgroup\$
  • \$\begingroup\$ I ended up removing cheat codes as an unrelated issue made it no longer desirable so this isn't an issue anymore. However if anyone still has any ideas on what might have caused it I'd like to hear. \$\endgroup\$ – Jason Crosby Feb 10 '18 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.