0
\$\begingroup\$

I have created a texture in Blender in texture paint mode. Main

Then I have started to add some details for side and corner texture. They are primarily height maps.

Side

Corner

I had some minor pixels being a different colour on the edges (don't know why they appeared). So I painted them out with colour picker. If you look at the texture (the one that I cleaned up is third) there shouldn't be any artifacts or missing pixels. Though, data from them was somehow stored inside the texture on different layer or what I don't understand that. As a result it created weird pixels that appear only on mip maps. Mip Map

Notice that original texture doesn't have these problems. Original

If I use image in texture on a displacement modifier in blender it uses that data to displace the mesh which is totally weird for me because I have painted out those pixels. Did I do something wrong? I have tried all the blending modes in Blender. I have tried to do everything I thought of in Krita, Paint, Paint3D.. I have changed the colours, erased the alpha, erased the colour and painted over and over again. Nothing helps. Even if the colour is set to bump the mesh, it uses the data normally but as soon as I change it back to neutral colour it uses wrong data again.

Blender

Result in Unity.Result

Original texture result Original result

All the settings are the same.

\$\endgroup\$
  • 3
    \$\begingroup\$ It looks like it's repeating, can you set it to clamp instead? Perhaps you need to add padding to the edges. \$\endgroup\$ – Sidar Feb 8 '18 at 20:37
  • \$\begingroup\$ @Sidar prnt.sc/ic2bh7 - didn't help, the original texture has Wrap Mode - Repeat and it's showing fine. \$\endgroup\$ – Candid Moon _Max_ Feb 8 '18 at 20:41
  • \$\begingroup\$ @Sidar I checked that and you were right, but it doesn't solve the problem. I have solved it by adding a margin to UVs but the mip maps don't care about Clamp. \$\endgroup\$ – Candid Moon _Max_ Feb 8 '18 at 21:59
  • \$\begingroup\$ @Sidar Thanks for your help, now I know where to look for the solution. It looks like you shouldn't use full width of the texture, so it's better to always leave some margin. You can leave your answer and I will accept it. \$\endgroup\$ – Candid Moon _Max_ Feb 8 '18 at 22:11
  • 1
    \$\begingroup\$ I wonder if compression artifacts play a part. See if this video helps at all. \$\endgroup\$ – sambler Feb 9 '18 at 13:52
1
\$\begingroup\$

Looks like you need some padding/margins in your texture so it doesn't bleed from edge to edge.

Edit:

I should probably elaborate, Ill probably come back to this ( can't right now ). So if someone else can elaborate that would be cool too.

\$\endgroup\$
-2
\$\begingroup\$

It is happening because of the mesh quality. Use a subsurf modifier or subdivide the plane

\$\endgroup\$
  • \$\begingroup\$ Not possible, it's a quad with UV mapping. It's just shader using values that are being projected on surface. \$\endgroup\$ – Candid Moon _Max_ Feb 25 '18 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.