7
\$\begingroup\$

I've been recently doing test builds of my game. In Unity, I worked on baking the lighting to ensure everything looked fine. However, upon building, the game level becomes far darker and much of the lighting and baking is ineffective.

Here is how the scene looks in the editor: Brightly lit image of a library

And here is how it looks in the built game: Darker image of a library

It's much darker than intended.

Here are my lighting settings which I've baked in Unity's Editor. These settings and lightmap parameters were designed to, at least in the editor, provide decent quality while making light bake times relatively quick. However, I've noticed that newer Unity's Lighting settings are way different now, so perhaps something is amiss here? enter image description here

I've been at my wits end trying to figure this out for the past while, but I can't figure out why this is happening or how to fix it. Any ideas?

\$\endgroup\$
  • \$\begingroup\$ Don't forget to include enough information about your lighting setup & configuration in the scene / graphics settings in the project so that we can reproduce the issue. \$\endgroup\$ – DMGregory Feb 3 '18 at 6:37
  • \$\begingroup\$ Added an image of my Lighting settings. Lights are one directional realtime light and several mixed spotlights. This has been an issue on default, but I have been experimenting with changing several of the project settings for a while and nothing seems to have changed. This includes the graphic settings, which hasn't seemed to improve anything so far. What should I be looking for? \$\endgroup\$ – JSparks Feb 3 '18 at 10:17
  • \$\begingroup\$ Which version of Unity are you using? \$\endgroup\$ – user100681 Feb 3 '18 at 11:58
  • \$\begingroup\$ Unity 2017.3.0f3 \$\endgroup\$ – JSparks Feb 3 '18 at 19:28
2
\$\begingroup\$

Unity will only take lighting from the active scene. So it's worth checking that:

  1. The scene is the "Active Scene" (bold highlight in hierarchy) when building lighting in the Edit Mode

  2. The scene is either the only loaded scene in Play Mode or you call SceneManager.SetActiveScene( scene ) for whichever scene you wish to take the lighting data from.

see: https://docs.unity3d.com/ScriptReference/SceneManagement.SceneManager.SetActiveScene.html

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.