0
\$\begingroup\$

After a long time of research, I saw that in January 2017, NVIDIA put a new driver that made crash every application running with LibGDX.

I would like to create a game with this library on Android Studio, but I always have this error :

Exception in thread "LWJGL Application" java.lang.NullPointerException
at com.mygdx.game.Screens.PlayScreen.render(PlayScreen.java:44)
at com.badlogic.gdx.Game.render(Game.java:46)
at com.mygdx.game.MyGdxGame.render(MyGdxGame.java:29)
at com.badlogic.gdx.backends.lwjgl.LwjglApplication.mainLoop(LwjglApplication.java:225)
at com.badlogic.gdx.backends.lwjgl.LwjglApplication$1.run(LwjglApplication.java:126)

I did not see anywhere that this problem has been fixed, so I would like to ask you if you know how to get over this error.

Thanks a lot,

Choumpsi

\$\endgroup\$
  • 1
    \$\begingroup\$ I highly doubt this has anything to do with graphics card drivers. One of your objects is just null when it shouldn't be. \$\endgroup\$ – Charanor Jan 28 '18 at 9:55
0
\$\begingroup\$

Go back to an older version of the driver if this is a problem?

Go to Device manager in windows > Find your Device > Right click it > Properties > Driver > Roll Back Driver

\$\endgroup\$
  • \$\begingroup\$ Hello, I already tried to download the driver 376.33, which seems to be the last one to work with the library. But it still doesn't work. \$\endgroup\$ – Choumpsi Jan 25 '18 at 14:06
  • \$\begingroup\$ Did you install 376.33 over the current driver or did you uninstall the current driver and then install 376.33 \$\endgroup\$ – Frenchie Jan 25 '18 at 14:11
  • \$\begingroup\$ I think I installed the 376.33 driver over the current one, I will try to uninstall it before. Thank you for the tip. \$\endgroup\$ – Choumpsi Jan 25 '18 at 14:13
  • \$\begingroup\$ No problem, failing this it's worth checking either related forums or the patch notes of older drivers. \$\endgroup\$ – Frenchie Jan 25 '18 at 14:16
  • \$\begingroup\$ Unfortunately, this tip didn't work. I did look for other solutions on related forums, but without succes. \$\endgroup\$ – Choumpsi Jan 25 '18 at 14:28
0
\$\begingroup\$

As @Charanor commented:

One of your objects is just null

You must have forgot to instantiate something:

at com.mygdx.game.Screens.PlayScreen.render(PlayScreen.java:44)

Check line number 44 in your PlayScreen

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.