0
\$\begingroup\$

I made first person model from Blender. In Blender, everything was fine. But move to Unity and hit play, some of mesh(Bullets in cylinder) are unstable, it's way to much shaking.

Few months ago, I was made another similar animation from Blender and that worked without this kind of issue. Only difference is that previous work, bullets and gun parts are single mesh but this is not, bullets and some of gun parts are seperated and parented. Does this occur this problem? If so, how should I avoid that?

Using Blender 2.78c and Unity 2017.3.0f3. Files downloadable from here:

Video link to explain this issue: https://www.youtube.com/watch?v=nlT1PIhUAHU&feature=youtu.be

.Blend https://drive.google.com/open?id=1kdjvRnyysuspcgtQ89udAucjUe0pBJc3

.FBX https://drive.google.com/open?id=1iOMrHc8aUMw50QhK_vNEKDgZEVCFo3Zx

\$\endgroup\$
  • \$\begingroup\$ I could be completely off about this since GPU rasterization isn't a strong of mine at all, but I would look into depth buffer precision differences as a possible explanation for this issue. Blender might use a much more precise version by default. Also everything's triangulated by the time it's imported into the engine, right? \$\endgroup\$ – user77245 Jan 13 '18 at 4:38
0
\$\begingroup\$

I'm still try to fix this issue, but couldn't find yet. But I can make them better by increasing frame rate of animation in Blender to target platform and turn off every animation related options(like error correction). Still weapons or bullets not sync perfectly, but it seems way much better.

Additional note: Using Inverse Kinematic causes this issue, and bake animation could be reduce this jittering issue. It's still not perfect, but seems better. But be careful, if you just overwrite original animation clip when you bake, you will loose all your IK animations and there is no going back.

\$\endgroup\$
  • \$\begingroup\$ If you are "still trying to fix this issue," why did you mark this as the answer? It's possible that doing so may dissuade others from answering since you are "satisified" with this state of being. \$\endgroup\$ – Josh May 17 '18 at 15:21
  • \$\begingroup\$ @JoshPetrie Because can't find any solution since I posted in here almost half year ago, and doesn't look like get a solution. If someone post correct answer, I accept it with pleasure. \$\endgroup\$ – modernator May 17 '18 at 15:26
  • \$\begingroup\$ That's fine, that's your prerogative. But I'd suggest that you don't mark the question as answered, or even that you just leave this note as a comment and not an answer. Posting it as an "answer" and then marking it as such means it will not show up on certain predefined searches people use to find "unanswered questions" they can answer. \$\endgroup\$ – Josh May 17 '18 at 15:30
  • \$\begingroup\$ @JoshPetrie Okay, thanks for suggestion, I didn't thought about that. I'd better cancel the accept. \$\endgroup\$ – modernator May 17 '18 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.