0
\$\begingroup\$

I just got a Razer 14 Inch 4k with a GTX 1060 and am having some blurry rendering in unity. Also the cursor is tiny... Here is a screen shot:

enter image description here

As you can see, the rendering is really blurry. I came from a mac and did not expect unity to look worse after switching to a computer with a great screen res and graphics card...

Please help!

EDIT:

I am still getting jagged shadows but now I seem to be able to fix it with changing shadow distance in Quality Project Settings:

Shadow Dist 150

Shadow dist 11

But then the shadow disappears really quick if i have low shadow distance...

\$\endgroup\$
  • \$\begingroup\$ 14 inch 4k screen? That seems really small for such high resolution! As for the blurring - are you sure your monitor is set to 4k resolution? What happens if you lower it (to say 1080p)? \$\endgroup\$ – Charanor Jan 1 '18 at 18:48
  • \$\begingroup\$ It gets worse. Everything zooms in \$\endgroup\$ – cipherous Jan 1 '18 at 19:14
  • 4
    \$\begingroup\$ This isn't anything to do with Unity specifically. Your hardware settings have to match each other. If your PC and monitor aren't both set to the same resolution, you'll get this kind of distortion. I'm using a GTX 1080 with no issues. \$\endgroup\$ – Stephan Jan 2 '18 at 17:45
  • \$\begingroup\$ I am not using a monitor. I am on my 14 inch laptop \$\endgroup\$ – cipherous Jan 4 '18 at 4:24
  • 2
    \$\begingroup\$ Ah... The good old low quality shadows with the Nvidia cards problem (Nvidia cards will set shadows low quality since they are a performance hog on the card, be sure that you've installed a recent driver). This is very normal (especially if you didn't tweak any settings). You need to tweak some settings to increase shadow quality: docs.unity3d.com/Manual/class-QualitySettings.html \$\endgroup\$ – John Hamilton Jan 4 '18 at 12:41
1
\$\begingroup\$

The Unity Editor doesn't work with DPI scaling on Windows yet, so on a high DPI display it's upscaled. You can disable that in Windows (using the Properties screen for the application) but that will almost certainly make the UI unusably tiny.

Unfortunately there is no way around this except to wait for Unity to add support in a later version.

Note that this only affects the Editor, and if you build your project and run it on the same machine, it shouldn't appear upscaled.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.