0
\$\begingroup\$

When I launched my game on my iPad, the screen first displayed a faulty splash image with a black lower half momentarily, before displaying the normal splash image.

No matter what I tried, I couldn't get rid of this faulty 'pre-splash image'. I have tried the following:

  1. Entered my Plus package serial number and updated my seat in Unity.

  2. Deleted and left all splash images blank in Unity.

  3. Checked all the LaunchScreen-XXX.png images in Xcode.

  4. Checked the files referenced by Images.xcassets in Xcode.

  5. Changed all the above images to a completely black image. Still, the old faulty picture would appear.

  6. Cleared all the data and installation files on my iPad.

  7. Deleted General > Launch Images Source.

I wonder where Xcode kept the faulty image.

I am using Unity 5.5.1 and Xcode 9.2.

Could someone please help?

\$\endgroup\$
0
\$\begingroup\$

I restarted the iPad and now it is working! I guess the issue had to do with the memory cache.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.