3
\$\begingroup\$

Hi I've have spent the past few days googling how to do this and I'm making no progress. I have created a png image for each of the sized icon 36x36, 48x48, 72x72,96x96, 144x144 & 192x192. But when I load my app on any device the default icon apps. This is preventing me from uploading my game to the store as I don't want users to have a game with no icon.

Can anyone help get these icons to actually appear. I have tried different devices, uninstalling the app and reinstalling but still no luck. Do the images have to be a certain format, or any setting need selecting with in unity to make them compatible?

enter image description here enter image description here

\$\endgroup\$
  • \$\begingroup\$ I haven't had this problem before. Did you recompile after adding the icons? \$\endgroup\$ – Draco18s no longer trusts SE Dec 14 '17 at 19:36
  • \$\begingroup\$ @Draco18s Hi, yes cleaned the solution and rebuilt. \$\endgroup\$ – Phil3992 Dec 14 '17 at 19:41
  • \$\begingroup\$ have you added it to the player settings ? \$\endgroup\$ – Uri Popov Dec 14 '17 at 20:56
  • \$\begingroup\$ @uri hi yep that's the only place I know where it can be done \$\endgroup\$ – Phil3992 Dec 14 '17 at 21:55
  • 1
    \$\begingroup\$ Well... This seem in order. I mean the texture type is wrong but I tried building my project with that setting and it worked. Are you building with gradel or the internal builder? Also what version of unity are you using. Try upgrading if you are using a older version. \$\endgroup\$ – Uri Popov Dec 18 '17 at 20:46
0
\$\begingroup\$

Update Unity to the latest stable version. The case is that probably android changed how the icon is represented in the resources and manifest and your version of unity builds the wrong things.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.