0
\$\begingroup\$

I have duplicated the blend tree from the ThirdPersonCharacter (Ethan) which comes with the Standard Assets package.

In the duplicate I went into the blend tree and swapped out the walk animation "HumanoidWalk" with my own animation named "walk", but now I get a weird transition from the animation "walk" to "HumanoidRun".

Both animations, my walk animation and the original "HumanoidWalk" are root animated and look similar they have around 1.5 velocity both and same frame length.

Animation Settings:

walk animation settings

I created the animation in blender, you will see in my video below that the animation itself runs smooth and as it should, but the transition to HumanoidRun is very weird for unknown reasons. I am using a custom metarig armature which comes with the blender add-on "rigify", I deleted some bones on the finger, but the avatar has a check and is ok (no warnings either).

Rig Settings

rig settings

Player settings

I basically "copied" all the components from Ethan (ThirdPersonController) and only changed the Animator Controller and the Capsule Collider settings to match the model.

enter image description here

I made some short videos where you clearly see the problem, it happens if the parameter Forward is at about 0.6 - 0.8.

https://youtu.be/Q-T7FplDxLE

https://youtu.be/nrJNeo1ltsg NOTE: First I am demonstrating how it looks with the normal animations, then I add my own.

What am I doing wrong?

More Infos:

I just baked the walk animation in blender and exported it to unity again, but this made no difference.

I tried to export it from blender as FBX, it made no difference. However, I noticed that the import is happening much faster and applying in unity importer is very fast now.

\$\endgroup\$
0
\$\begingroup\$

I figured it out. The problem is, that Ethan uses another armature than metarig, and thus it won't blend properly. I thought it will work, because I read that chapter about retargeting which promised that we can use humanoid animations for other models, but it seems like this is only true if both models use the exact same armature.

It finally works perfectly fine after creating my own run and idle animation and assigned them in the duplicated Animator controller.

I also asked the unity support, here is their answer:

We have tried changing some settings in your animation parameters and found that 'Blend type - 2D Freeform Directional' eliminates this weird blending issue. Try using that for your blend trees.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.