1
\$\begingroup\$

Spotlight

What i did is disabled in the Hierarchy the Directional Light. The Spotlight is child of the character so it will move with it.

Then in Window > Lighting > Settings

Light

In the Spotlight i just changed the range and rotation a bit. It's strange since it's showing the light in the scene view but not in the game view not even when running the game.

And this is the Spotlight config:

Spot

\$\endgroup\$
  • \$\begingroup\$ Are you accessing/controlling the spotlight in any way using a script? \$\endgroup\$ – user100681 Nov 23 '17 at 15:05
  • \$\begingroup\$ In the screenshots, the only problem is that your camera is not looking at the character and instead it's looking into the void. \$\endgroup\$ – John Hamilton Nov 24 '17 at 6:22
1
\$\begingroup\$

Found how to do it. In Window > Lighting > Setting: Skybox Material set it back to original: Default-Skybox then in Environment Lighting setting the color to black. Then in Environment Reflections: Intensity Multiplier set to 0 then in the Main Camera in the Inspector: Changing Clear Flags to SolidColor and changing the Back Ground color to black.

You can see all the settings in the next screenshot:

Working light

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.