2
\$\begingroup\$

If you place 3D Sound which is set to logarithmic falloff and move very fast, then it sounds extremly weird and plays way faster than normal. How can I prevent this?

Settings

I made a short video: https://www.youtube.com/watch?v=-bZJ7YS775E&feature=youtu.be

\$\endgroup\$
  • \$\begingroup\$ It might help if you also provided an example of the same sound without the "weird effects", so that we could tell what it's supposed to sound like. \$\endgroup\$ – Ilmari Karonen Nov 8 '17 at 16:11
  • \$\begingroup\$ @IlmariKaronen, I was standing still in the video sometime, this is how it sounds normal. \$\endgroup\$ – Black Nov 8 '17 at 16:57
  • 2
    \$\begingroup\$ For context, this is simulating something called the Doppler Effect, which makes sounds speed up / rise in pitch when you're moving toward their source (or their sources is moving toward you), and slow down / fall in pitch when you and the source are moving apart. It's what makes a passing car or train sound like vaaaeeeeeEEEEEEEEEOOWWwwwwwwww ;) \$\endgroup\$ – DMGregory Nov 8 '17 at 17:07
  • \$\begingroup\$ So all those note bends aren't actually part of the original sound clip? That would've been useful information to have. But I'm glad you managed to figure out the issue on your own. \$\endgroup\$ – Ilmari Karonen Nov 8 '17 at 17:10
4
\$\begingroup\$

I found the reason for this. It is a setting called Doppler Level. After setting it to 0 it sounds normal even if the audio listener is moving very fast.

Doppler Level to 0

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.