0
\$\begingroup\$

The following are pictures of what I am describing. This happens both when I have normal lighting, graphics on low, render distance on short. I have a graphics card that can run games like Starcraft II easily. It appears to be the top of the screen that is most often affected by this lag. The lag is also seen on terrain. It happens when I build and set quality to low as well. Even if I change the camera angle. Camera movement is irrelevant. Although I am using position to make the camera not momentum. Any idea what might be causing this?

Blurry unwanted And the following is what it cuts to when the renderer catches up: enter image description here It only appears when the background is either not rendered, or very far in the distance.

Yes I have tried restarting unity, yes I have restarted my computer.

Here is the image with the camera settings:

Camera pane

\$\endgroup\$
  • 1
    \$\begingroup\$ 1) the Snip tool is a Thing. 2) show us the camera properties in the inspector. \$\endgroup\$ – Draco18s Oct 14 '17 at 4:54
  • \$\begingroup\$ Added a snip of camera alongside showing how it is reproduce able on black background. \$\endgroup\$ – Jason Basanese Oct 14 '17 at 5:16
2
\$\begingroup\$

The problem is that I changed the Skybox to a black material that is not a "Skybox" even though it works. Never again will I ignore warnings:enter image description here

\$\endgroup\$
  • \$\begingroup\$ Yep, essentially, the render buffer isn't being cleared properly (you can get a similar effect by setting the Clear:Skybox dropdown to Clear:none on the camera). \$\endgroup\$ – Draco18s Oct 14 '17 at 15:59
  • \$\begingroup\$ Remember to pick this as your answer since it seems to have fixed your problem. \$\endgroup\$ – John Hamilton Oct 20 '17 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.