35
\$\begingroup\$

How can I change the Google Play Console language? Here you can see that the language is not English:

enter image description here

\$\endgroup\$
1
  • \$\begingroup\$ Have you checked your default preferred language in your Google Account settings? This help page seems to suggest that you could change it there. \$\endgroup\$
    – user35344
    Oct 7, 2017 at 12:41

5 Answers 5

27
\$\begingroup\$

From the Google Support Page:

The Admin console uses the same language you choose in your Account settings.

So to change the language you have to change your language in account settings. To do this follow these steps (from Google Support again):

  1. Sign in to your account.
  2. In the "Account preferences" section, select Language & Input Tools.
  3. Choose Language.
  4. To change your language, select edit Edit edit image.
  5. Choose your language from the dropdown box and select Ok.
\$\endgroup\$
2
  • \$\begingroup\$ i didn't find such menu.. but solved by changing language at the login page (bottom left, below the login form) \$\endgroup\$
    – mgear
    Sep 5, 2019 at 15:46
  • 2
    \$\begingroup\$ That might change, but right now that page is myaccount.google.com/language \$\endgroup\$
    – Nato Boram
    Aug 3, 2023 at 18:56
22
\$\begingroup\$

In the url change hl=ru to hl=en.

\$\endgroup\$
2
  • \$\begingroup\$ Hi duo, and welcome to GameDev.StackExchange! While this answer may correctly solve the issue, you might find your answers attract more upvotes if you also include a little more explanation of why it works. \$\endgroup\$
    – DMGregory
    Jan 18, 2018 at 17:49
  • \$\begingroup\$ You are a lifesaver!!! Does anyone know why this happens? \$\endgroup\$
    – Milo
    Dec 12, 2020 at 16:06
5
\$\begingroup\$

Nowadays, i could not see language prefs on Google Play Console. Instead of Play Console, you can change language via Google Account. After you click on it,

  • Click Data & personalization,
  • Scroll down the page until the General preferences for the web title and then you will see the Language preference. You can change account language with this way.

After you completed steps above, Go to Play Console. You will see the portal language which was changed.

\$\endgroup\$
1
3
\$\begingroup\$

You can do this by changing URL only. As it is a client account, I don't want to mess things up for him by changing whole account language so I only add parameter hl=en in the URL.

For example, change this:

  • https://play.google.com/apps/publish/?account=

Into this:

  • https://play.google.com/apps/publish/?hl=en&account=
\$\endgroup\$
2
  • \$\begingroup\$ This works. The easiest way. \$\endgroup\$
    – Bek
    Nov 12, 2019 at 7:46
  • \$\begingroup\$ Refresh the page and it's gone. \$\endgroup\$ Aug 9, 2022 at 15:00
1
\$\begingroup\$

I had same issue and changing account settings language didn't help. But I solved it by changing default Chrome language. So if you tried changing your account language settings and it didn't work, go to chrome://settings/languages and move your preferred language to the top. Reload page and it should work

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .