0
\$\begingroup\$

I have a big problem in my Unity game, in almost every scène of my game, my editor is laggy, when I record Porfile Editor / deep profile editor, here is the result: enter image description here

I have no idea what is this throttle MainMessageLoop, what can I do ? Thanks you !

\$\endgroup\$
4
  • 2
    \$\begingroup\$ I think they just renamed WaitForTargetFPS into Throttle MainMessageLoop, your game seems to be running at about 4ms update loop, which means 240FPS. gamedev.stackexchange.com/questions/124496/… \$\endgroup\$ Commented Sep 29, 2017 at 10:12
  • \$\begingroup\$ Disabled V-sync (both checkbox in editor or in edit>project setting>quality) don't do anything :/ even in a totaly new unity project ! So I will try to reinstall Unity... \$\endgroup\$
    – Ugo Hed
    Commented Sep 29, 2017 at 11:20
  • \$\begingroup\$ You seem to misunderstand me. This is like the System Idle Process in Windows, it's supposed to be "hogging the CPU" because it's doing nothing at all (which is better for the CPU than running your game loop 600 times per second). The editor lag is probably from something else (most likely those blue spikes that appear every few seconds on your profiler). \$\endgroup\$ Commented Sep 29, 2017 at 11:46
  • \$\begingroup\$ Agreed. If 90%+ of your frame time is coming from an entry taking 3-4ms in total, you're doing great! If you're noticing a stutter it's more likely the periodic editor repaint in the blue spikes. You might need to adjust how you're ticking forward your game time (using FixedUpdate/deltaTime/physics interpolation) to ensure variances in frame time don't create noticeable hitches in the gameplay. \$\endgroup\$
    – DMGregory
    Commented Sep 29, 2017 at 12:24

2 Answers 2

2
\$\begingroup\$

so thanks to John Hamilton & DMGregory, I found the problem, and figure out a "kind" of a solution. The blue spikes was throwing this types of error:

Unaccounted time between: GPUProfiler.BeginQueries

I download the last version (from Unity 5.6.1 to Unity 5.6.3) and the problem is solved.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Remember to pick this as the answer ;) \$\endgroup\$ Commented Oct 2, 2017 at 7:11
1
\$\begingroup\$

Hi i had same exact issue, turns out it was windows throttling performance down. Go to Power management settings and set your pc to Performance mode (i am on a desktop mind you), after that the stutter disappeared.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .