I am creating a VR game. Currently, I'm testing it on an Android device.

Now I when I run the application it runs smoothly and without any issue.

However when I add the following model:

enter image description here

And attempt to look at it the game crashes.

The model you see doesn't have any scripts on him only a transform component and an animator.

Has anyone tried something similar? or have an idea what the issue might be? Update i have also tried this following scene

So i tried to isolate the character completely from my original scene. So i made this:

enter image description here

Again if i have the character in the scene it crashes. if i remove the character it runs perfectly fine.

Another update:

If i remove the animator component from the model it works fine?

  • 1
    \$\begingroup\$ It sounds like the animation data or animator control graph may be corrupted in some way. Are you able to play all of the animations in the editor? Anything look strange in the control graph? Have you tried deleting the assets and re-downloading/importing them? Does game crash on PC/non-VR as well, or only on Android? \$\endgroup\$
    – DMGregory
    Sep 29, 2017 at 12:14
  • \$\begingroup\$ @DMGregory There are no animations attached to the animator it simply has the component. i also tried to remove the component and it still crashed. The game did not crash when i ran it on my PC / non-VR \$\endgroup\$ Sep 29, 2017 at 13:45
  • \$\begingroup\$ Your question says: "If I remove the animator component from the model it works fine" But your comment above says: "I also tried to remove the component and it still crashed" Which is it? \$\endgroup\$
    – DMGregory
    Sep 29, 2017 at 13:55
  • \$\begingroup\$ Sorry, i need to update the question again. it still doesn't work even if it was removed \$\endgroup\$ Sep 29, 2017 at 14:03
  • \$\begingroup\$ Can you tell us what model format this is? And also what software is being used to produce the model? \$\endgroup\$
    – Engineer
    Oct 1, 2017 at 4:56

3 Answers 3


You need to reimport the char, and make sure the quality of the texture as well as size of the char are as low as your computer cpu. deactive the animator and use another character with controller script on it view the crasher. If it dont work tell your modeler to stop messing around.


I would run this through a model converter. Since you don't specify your current format, something like Max or Maya or Blender or a third party converter such as Spin3D or the like. It may be that converting to another format picks up certain glitches and fixes them implicitly.

And you could always convert back again if you wish, before importing into Unity. But I'd try with one of the alternative formats first, then back-convert if that works.


Does the app crash when you place the component on a different gameobject? If it does then the animator component might be causing some issues. Perhaps it isn't supported by the Android version that you are using. I remember in the past the animator causing meshes to dissappear with android 5.0, so it might be something related to this.

Is there any error thrown or warning when you run the app in debug mode on android? Or a crash report perhaps? It would make it easier to pin down the exact problem.

As for now I can only think of using the Unity animation, more info can be found at https://docs.unity3d.com/ScriptReference/Animation.html it does require some coding though to get all animations right.

Perhaps there is some compability issue with the animator component (or even unity) and the android version on your phone, so updating or checking the versions for any compability issue might be a good check too.

If you have an error log available or something that gives us more insight about the crash it would help us greatly.

As a final tip I do suggest you to make use of known and supported model types such as .fbx or .obj as example, using types that aren't well known might not be recognized by the device which can cause crashes.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .