4
\$\begingroup\$

I recently installed Unity 2017.1.0f3. I imported a project from an older version of Unity it worked perfectly and allowed me to build for Android. I logged in to the Asset Store through the tab in the Unity editor, now I can no longer build for Android.

This is the error I receive:

Your license does not cover Android Publishing.

I created my Unity account before Android was free. Is there a way to update my account to allow me to build with Android again?

\$\endgroup\$
6
\$\begingroup\$

Trial and error solved my problem:

  1. Sign out, In the top right hand corner of the the editor click Account > Sign out [Your Name]:

Sign Out.

  1. Close Unity.
  2. Re-open Unity.
  3. It will ask you to login and choose your licence.
  4. You will now have the latest licence file.
\$\endgroup\$
0
\$\begingroup\$

In my case, I'm using unity hub and seems that it is the reason for the problem because I'm signed in the unity hub but not signed-in in the unity version I'm using

The solution is 1- Close current running version 2- Browse for your unity setup folder then open unity.exe (Not Open unity hub) 3- login and you can find everything is working fine

\$\endgroup\$
0
\$\begingroup\$

I had to update my license in Unity Hub.

Preferences -> License Management -> Check for Updates

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.