0
\$\begingroup\$

I have developed a small game for learning purpose and here is src of that, when I play the game GeForce FPS Counter is not displaying.

I thought there might be some kind of bug in my src. So, I installed two popular games developed using Unity.

  1. "Life is Strange: Before the Storm" - FPS not displaying.
  2. "INSIDE" - FPS displaying.

Can anyone tell me what is happening. And also I noticed that when playing "Life is Strange: Before the Storm" my CPU and GPU temperature goes hotter than playing "Rise of the Tomb Raider".

Note: I have played all the game in full screen mode and all settings to highest.

UPDATE:

Firewatch and INSIDE both shows FPS Counter. but, when Enable G-SYNC for full screen mode is selected, G-SYNC is not working in all the games developed using Unity even when launched in full screen mode. But when I enable Enable G-SYNC for windowed and full screen mode then the G-SYNC is working. But when it comes to Life is Strange: Before the Storm is not showing FPS Counter but shows G-SYNC indicator on the screen.

  • Is Unity games not actually runs in Full Screen mode?
\$\endgroup\$
  • \$\begingroup\$ @Bálint Yes FPS counter displays in Rise of the Tomb Raider, The Witcher 3, Resident Evil 7, Metal Gear Solid V The Phantom Pain, Hellblade Senuas Sacrifice, etc,. But one more that not displaying FPS counter is Batman The Enemy Within Episode 1(not Unity Engine). \$\endgroup\$ – Bala Krishnan Sep 3 '17 at 11:01
  • \$\begingroup\$ @Bálint thanks for that info. Do you think that ShadowPlay is also responsible for G-SYNC not working please check the updated question. \$\endgroup\$ – Bala Krishnan Sep 3 '17 at 12:22
  • \$\begingroup\$ Check if the issue comes up due to Exclusive Fullscreen as opposed to Borderless Fullscreen. \$\endgroup\$ – Galandil Sep 3 '17 at 12:44
  • \$\begingroup\$ @Galandil yes that's what causing G-SYNC not to work. But I don't know why developer is not choosing Exclusive Fullscreen mode. So, to summarize FPS counter is not working in "Life is Strange: Before the Storm" because Unity don't support ShadowPlay and G-SYNC is not working because the developer built the game with "Fullscreen Windowed". But its strange that the in-game settings has switching between Fullscreen and Windowed. \$\endgroup\$ – Bala Krishnan Sep 3 '17 at 13:02
  • \$\begingroup\$ Probably that's because, before 5.3.4p2 iirc the version, exclusive mode had several bugs when used, so devs opted out of it and sticked to the borderless window. You can try to use the argument -window-mode set to exclusive or borderless on the standalone. BTW, I'd stick to borderless when devving, because D3D12 doesn't allow exclusive fullscreen at all. \$\endgroup\$ – Galandil Sep 3 '17 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.