1
\$\begingroup\$

I am very new to Unity and was just testing out a few things to make my first ever game. I tried to make a material for my obstacle and I noticed that there is some texture issue. It shows pink lines and all other colors when at a close look. This can also be seen when the material color is brighter. How would I fix this?

My Unity version is Unity 2017.1.0f3.

The bottom right is how the texture should look and the rest is the texture outcome. Even in the preview on the assets folder show this issue.

enter image description here

\$\endgroup\$
1
\$\begingroup\$

Here are some clues :

GPU

Make sure your GPU can handle the version of DirectX Unity is using (example : Unity running with DX11 and GPU was only capable of DX10). Build Settings PC, Mac & Linux Standalone -> Other Settings -> Rendering : Disable Automatic Graphics API and reorder the list of Graphics APIs for Windows that appears so that DX11 is at the bottom.

DirectX

Lightning

Go to the top menu: Window -> Lighting -> Scene. Uncheck Auto at the bottom of the panel and click on Clear baked data in the dropdown menu next to the Build button.

Also, in the Lightning panel, under the Environment Lightning section, set to Uncompressed the Reflection Source -> Compression field.

Lightning

Shader

Try to download the shaders assets of Unity and use the downloaded Standard shader

Reflections

Turn off the HDR in Cubemap capture settings for the reflection probe

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.