This is screenshot of not playing mode. You can see the the speedloader and bullets inside of the revolver.

enter image description here

And this is when playing mode.

enter image description here

As you can see, I can see the speedloader and bullets in scene view, but not player's camera. Sometimes, it disappears in scene view either!

I made this model same as other weapons, but others are working fine. Only this weapon causes this problem. All weapons that I made are based on same model and rigs, and I kept the weapon's scale fit as same as possible.

I tried move the camera and scale down a little bit, but still couldn't saw.

Why this is happening? How do I solve this? Any advice will very appreciate it.

  • 2
    \$\begingroup\$ maybe your issue is related to this question? \$\endgroup\$ – qCring Aug 8 '17 at 12:50

Solved! Just check "Update when offscreen" of Meshrenderer component!

  • 1
    \$\begingroup\$ If Unity is detecting that your MeshRenderer is offscreen, then its origin or bounds might not be correctly reflecting the range of its animation. Using this setting is probably safe for the player themselves, since their hand/weapon meshes will almost always be on-screen, but you want to be cautious using it for other characters/objects, otherwise you may burn cycles updating content your player can't see. \$\endgroup\$ – DMGregory Aug 8 '17 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.