0
\$\begingroup\$

My project was working fine when I was at Unity 5.4,

As soon as I upgrade my project to 5.5 It start giving me this error when I try to build apk, so couple of days back I upgraded it to 5.6.1f1 and well it is giving me same error at time of building. (BUILDING FOR ANDROID)

Failed assemblies stripper: E:\Unity\Editor\Data\Mono\bin\mono.exe "E:\Unity\Editor\Data\Tools/UnusedBytecodeStripper.exe" -l none -c link -a "Assembly-CSharp-firstpass.dll" -a "Assembly-CSharp.dll" -a "Assembly-UnityScript-firstpass.dll" -a "Assembly-UnityScript.dll" -out output -x "E:\Unity\Editor\Data\Tools\link.xml" -d "Temp/StagingArea/Data/Managed" -x "tmplink.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\AI.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Animation.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Audio.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Cloth.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Core.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\CrashReporting.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\IMGUI.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Input.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\JSONSerialize.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\ParticlesLegacy.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\ParticleSystem.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\PerformanceReporting.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Physics.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Physics2D.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Terrain.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\TerrainPhysics.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\TextRendering.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\UI.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\UNET.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\UnityAds.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\UnityAnalytics.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\UnityConnect.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\UnityWebRequest.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\UnityWebRequestAudio.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Vehicles.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Video.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\VR.xml" -x "E:\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Whitelists\Web.xml" current dir : Temp/StagingArea/Data/Managed
result file exists: False. Timed out: False

stdout:

stderr:

Unhandled Exception: Mono.Linker.ResolutionException: Can not resolve reference: UnityEngine.Vector2 UnityEngine.Vector2::SmoothDamp(UnityEngine.Vector2,UnityEngine.Vector2,UnityEngine.Vector2&,System.Single)

  at Mono.Linker.Steps.MarkStep.MarkMethod (Mono.Cecil.MethodReference reference, System.Object markedby) [0x00000] in <filename unknown>:0

  at Mono.Linker.Steps.MarkStep.MarkInstruction (Mono.Cecil.Cil.Instruction instruction, Mono.Cecil.MethodDefinition markedby) [0x00000] in <filename unknown>:0

  at Mono.Linker.Steps.MarkStep.MarkMethodBody (Mono.Cecil.Cil.MethodBody body) [0x00000] in <filename unknown>:0

  at Mono.Linker.Steps.MarkStep.ProcessMethod (Mono.Cecil.MethodDefinition method) [0x00000] in <filename unknown>:0

  at Mono.Linker.Steps.MarkStep.ProcessQueue () [0x00000] in <filename unknown>:0

  at Mono.Linker.Steps.MarkStep.Process () [0x00000] in <filename unknown>:0

  at Mono.Linker.Steps.MarkStep.Process (Mono.Linker.LinkContext context) [0x00000] in <filename unknown>:0

  at Mono.Linker.Pipeline.Process (Mono.Linker.LinkContext context) [0x00000] in <filename unknown>:0

  at UnusedBytecodeStripper.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 

What I tried,

  • Removed old plugins

  • No method in code uses Vector2.SmoothDamp

  • Tried to exlude Vector2.Smoothdamp from stripping https://docs.unity3d.com/Manual/iphone-playerSizeOptimization.html

  • Reimported ProjectS

  • Stripping set to OFF works but it increases apk size by 20mb which in turns make my overall apk size 100+mb. (Google play only allows upto 100mb size at a time without bundles) & its working with exact same settings in Unity 5.4

Please help in.

Its been 8 days I am stuck at this issue, my game is complete, just to use Splash Screen Tools, I upgraded my project and this happened.

\$\endgroup\$
  • 1
    \$\begingroup\$ There's an idiom in our language that roughly translates to "Don't change horses while you're crossing the river.", which means you really should stick to what tools you have until you complete the task at hand. I'm sure there are pretty huge changes between 5.4 and 5.5 and I know from experience that 5.5 and 5.6 have just too many differences between them. My suggestion is to keep using 5.4 unless you absolutely have to upgrade. \$\endgroup\$ – John Hamilton Jun 17 '17 at 8:59
  • 1
    \$\begingroup\$ You are correct that's why I upgraded when compelte game is ready ,just for new SPlash Screen Tools only aviable from 5.5+, \$\endgroup\$ – idurvesh Jun 17 '17 at 10:26
  • \$\begingroup\$ + 5.6 is a total disaster cause they've made tons of bugs in particle systems and fixes will come in a month or so. :) \$\endgroup\$ – Jacob Jun 17 '17 at 17:27
  • \$\begingroup\$ Ohkk, but what does it mean to my problem? \$\endgroup\$ – idurvesh Jun 18 '17 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.