1
\$\begingroup\$

I am trying to make a plain white room in Unity. I used six planes for the walls, but I can't figure out how to get the lighting to not look so harsh and uneven. The top picture is my best attempt using two directional lights, and the bottom picture is the look that I am trying to replicate. It is from a demo scene in the Google VR SDK 1.50 for Unity. It uses only a single point light, but when I turn it off in the scene view, it doesn't change the appearance of the room at all. How can I make my room look more like the Google VR demo?

My attempt at a room

Room from GVR SDK 1.50 demo scene

EDIT: I made a big improvement by changing all my walls to be static so that they receive indirect lighting, and adding a single point light above the roof.

Improved lighting

\$\endgroup\$
  • 2
    \$\begingroup\$ Looks like the second is using baking to include indirect lighting (global illumination). This models light bouncing off of bright surfaces and illuminating their surroundings, giving that softer, more even look. Have you explored using Unity's global illumination features? \$\endgroup\$ – DMGregory Jun 8 '17 at 14:02
  • \$\begingroup\$ @DMGregory Thank you, the indirect lighting is a big improvement. \$\endgroup\$ – Arti Schmidt Jun 8 '17 at 17:54
  • \$\begingroup\$ If that solved your problem, it would be worth sharing the settings you used and the results you achieved as an answer, to help future users with similar problems. \$\endgroup\$ – DMGregory Jun 8 '17 at 18:12
2
\$\begingroup\$

You have two lights in your scene. One of them is probably the default Directional Light, which is causing your scene to look unevenly lit.

enter image description here

The demo scene only has a single Point Light at the top of the room.

\$\endgroup\$
  • \$\begingroup\$ I need both directional lights so that all of the walls are lit up. When I use a point light, I get extremely bright and dark areas, unlike the scene I am trying to model. \$\endgroup\$ – Arti Schmidt Jun 8 '17 at 14:24
  • 1
    \$\begingroup\$ @ArtiSchmidt You should instead alter the ambient light. Window -> Lighting -> Ambient Light \$\endgroup\$ – Draco18s Jun 8 '17 at 14:28
  • \$\begingroup\$ When I use only an ambient light color without any other lights, the whole room becomes a single color, and there are no shadows that indicate there are corners and edges in the room. \$\endgroup\$ – Arti Schmidt Jun 8 '17 at 14:35
  • 3
    \$\begingroup\$ @ArtiSchmidt You still need the point light. I'm telling you to use the ambient settings instead of the directional light(s). \$\endgroup\$ – Draco18s Jun 8 '17 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.