1
\$\begingroup\$

We are using Unity 5.5 and Parse 1.7.0 (and Firebase for notifications) which doesn't have "Parse.Unity.dll" and while on Editor everything is working fine but when we build using "IL2CPP" on iOS; while running on device the game produces an error of "MissingMethodException: No constructor found for Parse.Common.Internal.FlexibleListWrapper`2".

I think it's because of stripping, I've tried to include "Parse.Core" and "Parse.Common" in "link.xml" but still same error while I was looking for solutions I found that there's a file "Parse.Unity.dll" that should have been in the project from the start but when I try to include it in our project another error but this time in Unity Editor that says "System.Threading.Tasks.Task is defined multiple times" and that's because -I think- the new Parse.Unity.dll and Unity.Task.dll from Firebase, if I try to delete that firebase Dll another error appears....

Please any help is appreciated :(

We have to build with il2cpp to upload on the App store, Android version works fine.

\$\endgroup\$
  • \$\begingroup\$ Wait, isn't Parse shut down now? \$\endgroup\$ – DubGamer87 Jun 1 '17 at 8:17
  • \$\begingroup\$ @DubGamer87 yes, but parse-dashboard are working fine and "supposedly" with unity too; you have to host on your own server (i.e: heroku). We are using parse for other apps but Unity support is dead, I assume. \$\endgroup\$ – Paperbag Jun 1 '17 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.