6
\$\begingroup\$

In the scene where the occlusion culling is done as desired,

When I change the camera to orthographic, occlusion culling is not done.

(Look at the sphere the red arrow points to on the right)

enter image description here

What should I do?

\$\endgroup\$
2
  • 2
    \$\begingroup\$ Please don't post the same question on multiple stackexchange sites. \$\endgroup\$ Commented May 17, 2017 at 11:35
  • \$\begingroup\$ You're better off asking directly to the Unity guys. It looks like a bug but I can't be certain. \$\endgroup\$ Commented Dec 11, 2017 at 15:04

1 Answer 1

0
\$\begingroup\$

I would recommend checking the settings of the orthographic camera to ensure that the occlusion culling is enabled. This can be done by selecting the camera in the scene and navigating to the "Camera" component in the Inspector tab. From there, expand the "Occlusion Culling" section and ensure that the "Use Occlusion Culling" checkbox is ticked.

If the occlusion culling is already enabled for the orthographic camera, then there may be an issue with the occlusion culling algorithm itself. In this case, I would suggest experimenting with different occlusion culling settings or using a different algorithm altogether. It may also be helpful to consult Unity's documentation or seek advice from other developers on forums or communities.

\$\endgroup\$
1
  • 2
    \$\begingroup\$ "from other developers on forums or communities"? Did ChatGPT write this? \$\endgroup\$
    – Basic
    Commented Jun 11, 2023 at 23:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .