0
\$\begingroup\$

I have a particle system, which is supposed to be highlighting an important game object, but the Particle System doesn't show on the game window unless the Scene window camera has the Origin (0,0,0) in view. The origin is at the corner of my UI canvases, in which you can see the two white lines marking the edges.

Take a look at these screenshots. On the 1st screenshot, the particle system is not visible. The 2nd screenshot was taken just moments later and the particle system is completely visible (and the number of particles is as if it had already been emitting the whole time.) The only difference is that I slightly rotated the camera of the Scene Window in between screenshots. The camera was rotated down just a tiny bit to put the origin visible in the scene view.

The particle system immediately becomes visible on the game window as soon as I rotate the SceneView camera so that the Origin is in view.

enter image description here

enter image description here

This is Unity version 5.6.0f3.

There are other questions about particle systems not working, but the cause and solutions appear to be very different.

Here are things I've already tried:

  • The particle system is already set to "Play on Awake" both before and after rotating the camera.
  • I've ensured that all of components and game objects are visible and enabled both before rotating toward the origin and after.
  • All of the particle settings (size, etc.) are correct both before rotating to the origin and after.

Why is the particle system not visible without the origin in the scene view?

\$\endgroup\$
  • \$\begingroup\$ Hey @LVBen! What is your actual question? Your post seems a little all over the place and slightly hard to understand. Is there any way you could try to rephrase it to be a little less convoluted? Thanks! \$\endgroup\$ – Savlon May 7 '17 at 0:09
  • \$\begingroup\$ Hi @Savlon, The question is "Why is my particle system not visible without the origin contained in the scene view?" I cleaned up the post a little bit. \$\endgroup\$ – LVBen May 7 '17 at 4:26
  • \$\begingroup\$ What is the emission type/shape of your particle system? It may be facing away from the camera causing the emissions to only show from a certain angle \$\endgroup\$ – Savlon May 7 '17 at 4:30
  • \$\begingroup\$ The particles are skinny rectangular prisms with mirrored textures on both sides. If the scene view cannot see the origin, the particles are not visible from any angle. If the scene view can see the origin, the particles are visible from all angles. The particles rotate with the object, so if this was a an issue with normals to/away from the camera, then I'd expect the particles to alternate between visible/invisible as the object rotates. That isn't happening. The only factor determining whether or not the particles are visible is if the origin has ever been in scene view in that scene. \$\endgroup\$ – LVBen May 7 '17 at 4:43
  • \$\begingroup\$ Ahh I see. It could be something implemented by unity to increase performance. If the origin of the particle system is not showing then it may put it to sleep to save resources. I'm not at my computer right now, but try using the particle emitter, renderer and animator components instead of the basic particle system. That may give you more options to prevent it from sleeping. \$\endgroup\$ – Savlon May 7 '17 at 5:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.